Pod2g: iPhone 3GS And iPod Touch 3rd Gen Will Be Compatible With iOS 5.1.1 Untethered Jailbreak

Recently, Pod2G put up a list of all the devices that will be compatible with his upcoming iOS 5.1.1 untethered jailbreak. Unfortunately, the iPhone 3GS, AppleTV 3 and iPod Touch 3rd Gen devices weren’t compatible with the jailbreak. That has changed and the hacker (@Pod2g) has confirmed that the iPhone 3GS and the iPod Touch 3rd Gen will be compatible with the new jailbreak.

A lot of users were sad that the iPhone 3GS and iPod Touch 3rd Gen wouldn’t be compatible with the untethered jailbreak, but that’s not the case anymore. Pod2g just tweeted that he has found a way to get the jailbreak working on the iPhone 3GS and iPod Touch 3rd Gen, however, AppleTV 3’s status remains the same. Here’s the updated list of devices that are now compatible with the iOS 5.1.1 untethered jailbreak:

  • iPhone 4
  • iPhone 4S
  • iPad 1
  • iPad 2 Wifi
  • iPad 3 Wifi
  • iPad 3 CDMA
  • iPod 3G
  • iPod 4G
Here is the list of devices that won’t be supported :
  • AppleTV 3
Remains to test (but that should work) :
  • iPhone 3Gs
  • iPad 2 GSM
  • iPad 2 CDMA
  • iPad 2 Wifi, R2
  • iPad 3 Global
  • AppleTV 2

There you go all iPhone 3GS and iPod Touch 3rd Gen users! No reason to be sad now, as your device will work with the latest jailbreak. The release of the untethered jailbreak is still some weeks away.

How many of you were excited to hear this news? Let us know in the comments.

Don't forget to follow iJailbreak.com on Facebook, Twitter and Google+.
  • FuckApple

    i got ipad 2 GSM if u want to test just contact me :D

  • Dante Kazuma

    so you a list that can’t run it but i don’t see Ipod 2G…does it mean Ipod 2G might be able to run it? Please someone  give me an answer.

  • Abdullah

    Hi , What R2 mean ?
    what’s the difference between iPad 2 Wifi, ((R2)) and normal iPad 2 Wifi ?

  • Tst

    Apple recently released a refreshed iPad2 with a small dye process, 32nm I believe

  • Pingback: Upcoming iOS 5.1.1 Jailbreak Will Support iPhone 3GS, iPod Touch 3rd-Gen

  • Jahnkeanater

    Apple stopped supporting the iPod 2nd Gen at 4.2.1.

  • Aayza

    No it means its not supported iOS 5.1.1 final

  • Dantekazuma

    thanks now im moving on to android cuz apple sucks fuzzy monkey balls for this bullshit….expecting me to buy another one again…fuck this shit….Thanks tho for letting me know

  • Hasib1522

    i dont have wifi, bt, imei, iccid etc, will tht be fixed? please say yes! :-(

  • Daniel_iPhoneinator

    THANK YOU POD2G!!!! :D!!

  • japz2fast

    cant wait….=)

  • Cis_0426

    i got ios 5.1.1 bb 4.12 untethered.. problem is how to unlock?

  • SAMple

    by the way jailbreak 5.1.1 untethered iphone 4,, my other 2 iphone 4 bb 4.11 both just got unlock last 10hrs ago by SAM, now got patch again.

  • No 1

    Plz now guys test iPad 2 gsm

  • Glen Hunter

    Hail the hackers!

  • Muzika

    Thanks you Pod2g!!!! Superb job! You are a genius!

  • Gmanager67

    Please try it on iPad 2 gsm

  • Mohd Adam

    Pod2G for the win!

  • waffs

    same goes for android as well… i have an htc desire and it doesnt support icecreamsandwich

  • Pikes_13

    nice pod2g,, great job!

  • B Rad77

     htc might not support ics(icecreamsandwich-android 4.x) on the desire but with the massive community of Android developers now you can get it for any android phone. (i’m using ics on a cheap htc wildfire and it works a treat)
    ANDROID IS THE FUTURE PEOPLE!!!!

  • Kaizer419

    where can i download the application??

  • http://profile.yahoo.com/HW7XM4E46MSRYYG4THYG4QX6HA Jacob

    when is this jailbreak suppose to be released

  • Jiro Alvarez

    Pure genius!

  • http://twitter.com/majklbiker Michal Beran

    super, you’re number one, thanks

  • FuckApple

     dude iPod2G which era u from? its like asking them to make sure iOS 5.1.1 should work on iPhone2G LOL

    those are crap instead of moving to android which suxs big time except Samsung G S3 u should have said time to upgrade haha

  • Timbhmaxx22

    I am not very good at this stuff , but my iphknebis out of warranty so i wanted to sind out what all the fuss is about jailbreaking ? So Is it possible to restore the iPhone 3GS that has 5.1.1 jailbreak back to normal if I jailbreak it ? And if so can I get a link to some detailed instructions ?

    Timbhmaxx22@yahoo.com

    Thanks.

  • Jumba

    YAY!THANKS but please try to hurry for the 3gs i am so sick of tethered boot!

  • yopiy

    download ultrasn0w from cydia.

  • Shaynekeator

    I need a little help. I have a iphone 3gs. I had the 5.1 tethered jailbreak, but decided to try for the untethered 5.1.1 jailbreak. I upgraded my iphone to the 5.1.1 firmware and then downloaded absinthe 2.0.1.

    I did what the absinthe directions said to do, which was: “Once your backup is complete return to your device and go to Settings – General – Reset – Erase All Content and Settings. This will make the jailbreak process much faster.”

    I started the absinthe jailbreak and then i got an error saying,”The attached device is not activated. You need to activate it before it can be used with Absinthe.”

    What did I do wrong, and what should I do to fix it? I have a TMobile sim card so obviously I can’t activate an iphone with that. The original owner/friend that gave me this iphone has an AT&T sim card, but it’s for the iphone 4, so it won’t fit this phone right? I have another friend with an AT&T sim card. Will his sim card work to activate my phone? Will it mess up his sim card if I try to use it?

    Any help would be greatly appreciated.

    Thanks

  • Sajid Ali

    Hi Every one,
    I have a problem can some one please tell me what to do?
    I have iphone 3gs with ios 4.0, can i upgrade it to ios 5.1.1 and jailbreak it? one more thing which is really disturbing is that i dont have the sim card and i dont know with which operator its locked. 
    So the problem is can i upgrade it to ios 5.1.1, and then jailbreak it without original operator sim card? PLEASE HELP :(

  • Testmailgbx

     hi, i have same problem that i think , the soluce is you search an any tmobile sim card to activate it,