Sn0wbreeze Updated To Jailbreak The iOS 5 Beta 2 Firmware! [Sn0wbreeze 2.8b3]

iH8Sn0w recently tweeted that he has updated Sn0wbreeze to Jailbreak the iOS 5 Beta 2 firmware. If you are a developer and currently have the iOS 5 Beta 2 firmware installed on your iDevice you can now Jailbreak it using Sn0wbreeze 2.8 beta 3 (tethered of course). It is also handy to note that if you have an iPhone 3GS running the iOS 5 Beta 2 firmware you can Jailbreak it Untethered (old bootrom only).

Take a look at iH8Sn0w’s tweet below:

Supported Devices:

  • iPhone 3GS (old bootrom) [UNTETHERED]
  • iPhone 3GS (new bootrom) [TETHERED]
  • iPhone 4 GSM [TETHERED]
  • iPhone 4 CDMA [TETHERED]
  • iPod Touch 3G [TETHERED]
  • iPod Touch 4 [TETHERED]
  • iPad 1G [TETHERED]

Note: Sn0wbreeze 2.8 beta 3 does not Hacktivate or add afc2 in this release to prevent piracy.

If you would like a helping hand Jailbreaking with Sn0wbreeze 2.8 beta 3 please follow our step-by-step guide to Jailbreaking with Sn0wbreeze (ensuring you use the correct version of Sn0wbreeze of course).

Don't forget to follow iJailbreak.com on Facebook, Twitter and Google+.