How To: Unlock Your iPhone 4 Or iPhone 3GS On iOS 6.0.1 With UltraSn0w Fixer For iOS 6.0.1

Moments ago we told you that UltraSn0w Fixer was updated to be compatible with the iOS 6.0.1 firmware, and in case this is your first time using UltraSn0w Fixer we are providing a step-by-step tutorial. In this tutorial we will cover how to unlock your iPhone 4 or iPhone 3GS on a compatible baseband running the iOS 6.0.1 firmware.

UltraSn0w Fixer for iOS 6.0.1 works on the Jailbroken iPhone 4 or iPhone 3GS with one of the following baseband versions - 01.59.00, 04.26.08, 05.11.07, 05.13.01, 05.12.01 or 06.15.00.

How To Unlock iOS 6.0.1 With UltraSn0w Fixer

Step 1) - The first thing you will need to do is Jailbreak your iPhone 4 or iPhone 3GS on the iOS 6.0.1 firmware. For instructions on how to do this click here.

Step 2) - Now launch Cydia from your SpringBoard (homescreen), go into the Manage tab, Sources section, tap the Edit button and then the Add button. You will need to add the iparelhos repository:

http://repo.iparelhos.com

Step 3) - With the iparelhos repository added, you will now need to install the official version of UltraSn0w. That is right, you are not going to install UltraSn0w Fixer for iOS 6.0.1 first, but rather the official version of UltraSn0w.

Step 4) - Once UltraSn0w has been installed, now you will need to install UltraSn0w Fixer for iOS 6.0.1 to your iPhone.

When both UltraSn0w and UltraSn0w Fixer for iOS 6.0.1 are installed, you should have an unlocked iPhone that is compatible with any SIM card! If you have any further questions or thoughts please direct your attention to the comments section below.

Don't forget to follow iJailbreak.com on Facebook, Twitter and Google+.
  • hot line

    good jop man

    how to restore to ios 6.0.1 wath out up date baseband
    ihave iphone 3gs baseband 05.13.01 plz hlpe

  • apple

    when the fuck is this coming out for 4s????? shit

  • Gaara

    Great thank you very much for this good info. i will ask all my friend to unlock they iPhone 4 , and i will make some few $$. if i do i will donate some to this site .

  • http://www.facebook.com/baqeee Baqari Gvishiani

    i cant restore to 6.0.1 it says device is in dfu instead recovery plz help

  • Kevin

    When i install the Fixer it gives me two red lines

    Sub-process/usr/bin/dpkg returned an error code (1)
    dependency problems – leaving unconfigured

  • derick

    i got the same problem

  • http://twitter.com/AnumRiz Anum Rizvi

    hi i am first time on this website. i have iphone4 and current version is 4.3 (8F190) and the firmware is 04.10.01. can i update my mobile to 6.0.1 and unlock it?

  • Ed

    Using mobile terminal, I found out that the error is from the fixer trying to use ultrasn0w 1.2.3, not the latest version (1.2.7?)

  • jon

    I’m all so have the same problem. Is there any way to fix it?

  • Irek

    When i install the Fixer it gives me two red lines

    Sub-process/usr/bin/dpkg returned an error code (1)
    dependency problems – leaving unconfigured

    any my iphone still is not compatible with any SIM card! :/

    any sugestions?

    BB 06.15.00

  • http://www.facebook.com/WuErCe Irek Żwirek

    When i install the Fixer it gives me two red lines

    Sub-process/usr/bin/dpkg returned an error code (1)
    dependency problems – leaving unconfigured
    iphone 3gs
    BB 06.15.00

    and my iphone still is not compatible with any SIM card :/
    any sugestions?

  • http://www.facebook.com/WuErCe Irek Żwirek

    looks like this

  • Octavia

    i do have the same problem. any idea how to fix it? please

  • DN

    Also getting the exact same error message. Also iPhone 3GS on BB 06.15.00

  • Chancey

    I read on the cydia jailbreak and unlocking help page that you need to downgrade off of the ipad baseband. going to try it now

  • http://www.facebook.com/WuErCe Irek Żwirek

    have U try to downgrade to the ipad baseband? please write if this work or not.

    waiting for reply.

  • Ed

    The solution to the sub-process error that worked for me was reinstalling cydia 1.1.8. After that, i had no more issues.

  • kazmi

    does not work, on 3gs 6.0.1 with BB 6.15.00

  • Safat

    this doesnt work for me, what should i do, I am using a 3gs, old BR, BB 06.15.00 ?
    Please help.

  • StLaz_Habsfan

    anybody have a workaround for 3gs 6.0.1 BB6.15.00 new BR? thanx

  • http://www.facebook.com/maulik.ranolia Maulik Ranolia

    Okay!! i got it figured…the instruction given here is true but somewhat miswritten.
    1) Firstly, you need to install Ultrasn0w Fixer for IOS 6.0+ by the same repo as mentioned in the guide.
    2) AFter installing Ultrasn0w Fixer for IOS 6.0+, install Ultrasn0w 1.2.8…
    3) After this, eject your tray, reboot ur iphone with iBooty and voila!…your iphone is unlocked,,,,

    it worked for me with IOS 6.0.1(10A523) Baseband 05.13.04 on Iphone 3GS.
    Downgraded my Basebade from 05.16.07 to 06.15.00 to 05.13.04
    If you want any more help contact me on my facebook page : ranolia@gmail.com
    or here.Thanks

  • Fame

    Hi,

    How did you downgrade your baseband?

  • http://www.facebook.com/abasid.ismail A Basit Ismail

    S.O.S plz help!! i want to unlock my iphone4 ios 6.0.1 with baseband 04.12.02 your early respond is highly appreciated

  • louis

    Thanks, thanks, thanks very much…You saved my sunday…Good bless you…

  • mohib

    i did exactly as mentioned above.. 1st installed ultrawsnow and then ultrasnow fixer but i still get no service…. i’ve 3gs ios 6.0.1 bb 6.15.00

  • http://www.facebook.com/808HELLOKITTY Tommy Young

    It doesnt work how do i downgrade the baseband help asap please im on IOS 6.0.1 baseband is 4.12.02

  • http://www.facebook.com/balajim212 Shyamsundar Manian

    awesome..this worked…thanks!

  • Edong

    Thanks maulik for sharing this.. This freaking work! Guys, if your depending on ultrasnow for ios 6.0.1, BB 6.15.00 doesn’t work with ultrasnow and ultrasnow fixer! you have to downgrade to from 6.15.00 to 5.13.04.

    Thanks again maulik!

  • http://www.facebook.com/greg.hill987 Greg Hill

    i could only find ultrasnow 1.2.7 to instal
    I keep getting “no sim”
    I have ios 6.0.1 baseband 05.13.04, Ultrasnow 1.2.7 and Ultrasnow fixer for ios 6.X what do I do?

  • http://www.facebook.com/greg.hill987 Greg Hill

    I figured it out and it actually WORKS!!!

  • Chrispy

    Since this is tethered, will it still be unlocked if you dont do the “just boot steps”

  • Aini

    Yes, this works for me! It took me awhile but i finally manage to unlock the phone. Downgrade the baseband and followed this instruction again. But I only use redsn0w ‘Just Boot’ and not iBooty coz running on mac. Thanks alot Maulik Ranolia!

  • puiu_bb

    Hello guys my iPhone 3GS is jail broken at iOS 6.0.1 with redsn0w and now I try to unlock it with ultrasn0w…I tried 1 step to install ultrasn0w fixer and after that ultrasn0w latest version..but my phone it’s still No service…can you help me???…baseband is 06.15.00…I’m wainting the feedback…thanks!!!

  • Chris

    Worked for me too. Thanks a lot! Didn’t had to downgrade. Iphone 3GS IOS 6.0.1 Baseband 06.15.00. Just Installed Ultrasn0w Fixer and then Ultrasn0w.

  • Please Help

    Will my Iphone 4 with Basebad/Modem Firmware 04.12.02 unlocked? Please help., ^_^

  • http://www.facebook.com/maulik.ranolia Maulik Ranolia

    It will work with 6.15.00 baseband too but not with 5.16.07

  • http://www.facebook.com/maulik.ranolia Maulik Ranolia

    yes.you need ibooty(for window users) if you have downgraded the BB and in order to use jailbroken device..it needs to be started by it.:)

  • http://www.facebook.com/maulik.ranolia Maulik Ranolia

    check the step i have mentioned

  • http://www.facebook.com/martin.iglesias Martin Alejandro Iglesias

    does this still work? i cant download the repository

  • http://www.facebook.com/ameen.maharjan Ameen Maharjan

    i want to unlock my iphone 4 with baseband 4.12.05 with version 6.1.2, early response is hightly appreciated.

  • tony

    is it possible to use Cydia to unlock iPhone 4S with baseband 3.0.04 iOS 6.0.1

  • Em

    will this work for iphone 4s?