UltraSn0w Fixer Updated To Unlock iPhone 4 Or iPhone 3GS On iOS 6.0.1

A software based unlocking solution for the iPhone has been something we have been lacking for some time now because it is getting increasingly difficult to exploit the baseband of the iPhone. Now software unlocking solutions like UltraSn0w are only useful to those who have an older device and have preserved its baseband while upgrading to new firmware versions.

If you are one of the lucky few who rely on UltraSn0w to unlock your iPhone though, you will be glad to know an unofficial version is now available that brings compatibility with iOS 6.0.1.

The iPhone Dev-Team have yet to update the official version of UltraSn0w for iOS 6 compatibility, but just like last time UltraSn0w Fixer has been updated instead. UltraSn0w Fixer for iOS 6.0.1 is compatible with the iPhone 4 and iPhone 3GS on the following basebands — 01.59.00, 04.26.08, 05.11.07, 05.13.01, 05.12.01, 06.15.00.

If you would like to unlock your iPhone on the iOS 6.0.1 firmware with UltraSn0w Fixer for 6.0.1 you will simply need to add the 3rd party repository shown below. For those of you who do not know how to add a new repository into Cydia you will simply need to go into the Manage tab, Sources section, and then click the edit, followed by the add button.

http://repo.iparelhos.com

A more in-depth guide to unlocking your iPhone 4 or iPhone 3GS running the iOS 6.0.1 firmware with UltraSn0w Fixer for 6.0.1 will be coming your way soon. Until that time please stay tuned and leave any questions or thoughts about this temporary fix in the comments section below.

Update #1: For a detailed tutorial on installing UltraSn0w Fixer for iOS 6.0.1 click here.

Don't forget to follow iJailbreak.com on Facebook, Twitter and Google+. Be sure to check out our partnership page where you can get mentorship on starting your own business online.
  • Laci

    How can i update without BB Preserve? I Do it but cant boot because cant get out from Recovery (Missing plist error on redsnow)

  • Vini

    Work on iPhone 4, with BB 04.12.01 and iOS 5.1.1?

  • http://www.facebook.com/joejoseph.mccarthy JoeJoseph McCarthy

    cant add source its kinda verification error

  • jAyZ

    does this work on iphone 4 6.0 BB 04.12.02??

  • ssss

    I have an Iphone 3gs, baseband 6.15.00 . Done everything right: installed ios 6.0.1, jailbroken it with redsn0w, booted tethered, installed ultrasn0w and followed by the ultrasn0w fix, AND it still doesn’t work. I’m really fed up! Is there anything else that I can do?

  • jeoff

    i did the same thing as mentioned on the guide. fixer first then ultrasnow tool with baseband 6.15.00 but still no service..

  • jeoff

    i also did the other way around.. like i install ultrasnow toll then ultrasnow fixer but still nothing happens

  • jeoff

    im just hoping that we get the new update for ultrasnow which do not need a fixer for the latest version :)

  • iLlusion3D

    No just … Sam unlock Yes

  • skguy

    This does work for 3GS, if you are running 6.15.00 baseband then downgrade using redsnow, back to unlocked and fully functioning, don’t forget to tethered boot.
    THANK-YOU!!

  • skguy

    I did the same thing, and nothing. I’m looking for some sort of advice too, I would love to get it (3GS 6.15.00) back up and running.

  • skguy

    downgrade from ipad baseband using redsnow, should be back up and running

  • http://www.facebook.com/redpepper007 Ričards Pauls

    does NOT work on iPhone 4 iOS 6.0 baseband 04.12.02. Seems like the only possible method of unlocking this device is by IMEI… if anyone knows any other method, please email me richyp@inbox.lv

  • catie

    it worked for me. thanks!!! however as skguy says, i downgraded the baseband first.

  • http://www.facebook.com/Kularius Dariusz Kulczyna

    Im looking as well for solution to unlock baseband 04.12.02 – Orange UK IMEI unlock is so expensive that better wait…

  • http://www.facebook.com/Kularius Dariusz Kulczyna

    Sam unlock is working for 04.12.02 ??? I couldn’t unlock my iPhone 4 iOS 5.1.1 BB 04.12.02 with SAM… any advice please ???

  • moe

    but after downgrade you get baseband 05.13.04 which isn’t supported

  • http://www.facebook.com/christina.jaska Christina Jaska

    this didnt work i need to unlock my iphone 4 ios 6.0.1 for straight talk any help? please email me christinajaska777@msn.com